Posted by: Barly Wicaksono | 14 September, 2009

Routing RIPv2 di Cisco

The Routing Information Protocol (RIP) is a dynamic routing protocol used in local and wide area networks. As such it is classified as an interior gateway protocol (IGP). It uses the distance-vector routing algorithm. It was first defined in RFC 1058 (1988). The protocol has since been extended several times, resulting in RIP Version 2 (RFC 2453). Both versions are still in use today, however, they are considered technically obsoleted by more advanced techniques, Open Shortest Path First (OSPF) and the OSI protocol IS-IS. RIP has also been adapted for use in IPv6 networks, a standard known as RIPng (RIP next generation), published in RFC 2080 (1997).

——————————————————————————————————————————————

Pada awal settingan router cisco, kita menggunakan console untuk mensetting router. dibawah ini contoh gambar kabel console :

Router cisco memberikan fasilitas pengaman yang lebih dibandingkan router biasa. Karena pada Command Line Interfacenya kita dapat memberikan password untuk login dan juga untuk masuk ke mode previledge.

Sehingga, ketika kita ingin login ke router cisco tidak bisa sembarangan. Karena router telah diproteksi dengan password yang telah kita berikan.

Contohnya dibawah ini.

Caranya :

1. MENGAKTIFKAN LINE VTY (Virtual Terminal).

  • line vty 0 4 –> mengaktifkan 5 line virtual terminal yg digunakan untuk login maks 5 user secara bersamaan.
  • password cisco –> memberikan password dengan string “cisco”.
  • login –> statement ini, agar kita dapat login dengan dengan console dan password diatas.

2. MENGAKTIFKAN LOGIN CONSOLE.

  • line con 0 –> Jalur console yang kita gunakan untuk login adalah jalur 0.
  • password cisco –> memberikan password dengan string “cisco”.
  • login  –> statement ini, agar kita dapat login dengan dengan console dan password diatas.

Untuk mengetahui bahwa console dan virtual terminal telah aktif pada router, maka kita dapat melihatnya dengan mengetikkan perintah :

show running-config

Maka akan tampil seperti dibawah ini :


Current configuration : 477 bytes
!
version 12.2
no service password-encryption
!
hostname Router
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0
ip address 192.168.1.2 255.255.255.0
clock rate 9600
!
interface Serial0/1
no ip address
shutdown
!
ip classless
!
!

line vty 0 4

password cisco
login

line con 0
password cisco
login

3. Konfigurasi Router RIPv2

Jika kita ingin mengkonfigurasi router RIPv2, maka kita dapat menggambarkan diagram networknya seperti ini:

Net RIPv2

Net RIPv2

Dari gambar diatas, alamat-alamat ip dari router dan komputer yang terkoneksi. Berikut daftar IPnya :

  • Cabang A
  1. Interface Serial 0/0  : 192.168.1.2/24
  2. Interface FastEthernet 0/0 :  192.168.10.2/24
  • Kantor Pusat
    1. Interface Serial 0/0  : 192.168.1.1/24
    2. Interface Serial 0/1  : 192.168.2.1/24
    3. Interface FastEthernet 0/0  : 192.168.20.2/24
  • Cabang B
  1. Interface Serial 0/0  : 192.168.2.2/24
  2. Interface FastEthernet 0/0  : 192.168.30.2/24

Berikut merupakan perintah command linenya :

  • Cabang A

Router>en

Router(config-if)#no shut

Router#conf t

Router(config)#interface s0/0

Router(config-if)#ip address 192.168.1.2/24

Router(config-if)#no shut

Router(config)#interface fa0/0

Router(config-if)#ip address 192.168.10.1/24

Router(config-if)#no shut


  • Kantor Pusat

Router>en

Router#conf t

Router(config)#interface s0/0

Router(config-if)#ip address 192.168.1.1/24

Router(config-if)#no shut

Router(config)#interface s0/1

Router(config-if)#ip address 192.168.2.1/24

Router(config-if)#no shut

Router(config)#interface fa0/0

Router(config-if)#ip address 192.168.20.1/24


  • Cabang B

Router>en

Router#conf t

Router(config)#interface s0/0

Router(config-if)#ip address 192.168.2.2/24

Router(config-if)#no shut

Router(config)#interface fa0/0

Router(config-if)#ip address 192.168.30.1/24


Setelah semua setting IP selesai, maka kita kemudian mensetting Routing Protocolnya, dimana kita akan menggunakan Routing Information Protocol Version 2 (RIPv2).

Berikut settingannya pada masing-masing router :

  • Cabang A

Router>en

Router#conf t

Router(config)#router rip version 2

Router(config-router)#network 192.168.1.0

Router(config-router)#network 192.168.10.0

Router(config-router)#no auto-summary

  • Cabang B

Router>en

Router#conf t

Router(config)#router rip version 2

Router(config-router)#network 192.168.2.0

Router(config-router)#network 192.168.30.0

Router(config-router)#no auto-summary

  • Kantor Pusat

Router>en

Router#conf t

Router(config)#router rip version 2

Router(config-router)#network 192.168.1.0

Router(config-router)#network 192.168.2.0

Router(config-router)#network 192.168.20.0

Router(config-router)#no auto-summary


Jika kita sudah setting router secara lengkap, maka jika kita ping dari manapun, akan terkoneksi. kemudian kita akan cek apakah routing sudah berjalan dengan baik dengan cara mengetikkan sh ip route atau do sh ip route.

Maka akan tampil tulisan seperti dibawah ini :

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR P – periodic downloaded static route

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial0/0
R    192.168.2.0/24 [120/1] via 192.168.1.1, 00:00:17, Serial0/0
C    192.168.10.0/24 is directly connected, FastEthernet0/0
R    192.168.20.0/24 [120/1] via 192.168.1.1, 00:00:17, Serial0/0
R    192.168.30.0/24 [120/2] via 192.168.1.1, 00:00:17, Serial0/0

Tulisan diatas menunjukkan bahwa C merupakan kode dari Connected. sedangkan R merupakan arti dari RIP. Maka dapat kita simpulkan bahwa routing berhasil dijalankan.


Responses

  1. wah keren bener nih mas suhu barlie
    maenannya cisco sekarang…ckckck

  2. atas gw maho

  3. parah lo dit…
    ntu mah sodara kembar lo…
    hahaha…


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Categories

%d bloggers like this: