Posted by: Barly Wicaksono | 20 September, 2009

EIGRP Routing di Cisco

Enhanced Interior Gateway Routing Protocol – (EIGRP) is a Cisco proprietary routing protocol loosely based on their original IGRP. EIGRP is an advanced distance-vector routing protocol, with optimizations to minimize both the routing instability incurred after topology changes, as well as the use of bandwidth and processing power in the router. Routers that support EIGRP will automatically redistribute route information to IGRP neighbors by converting the 32 bit EIGRP metric to the 24 bit IGRP metric. Most of the routing optimizations are based on the Diffusing Update Algorithm (DUAL) work from SRI, which guarantees loop-free operation and provides a mechanism for fast convergence.

——————————————————————————————————————————————————————————

EIGRP (Enhanced Interior Gateway Routing Protocol) adalah routing protocol yang hanya di adopsi oleh router cisco atau sering disebut sebagai proprietary protocol pada cisco. Dimana EIGRP ini hanya bisa digunakan sesama router cisco saja. Bagaimana bila router cisco digunakan dengan router lain seperti Juniper, Huawei, dll menggunakan EIGRP ??? Seperti saya telah katakan diatas, EIGRP hanya bisa digunakan sesama router cisco saja.

EIGRP sering disebut juga hybrid-distance-vector routing protocol, karena EIGRP ini terdapat dua tipe routing protocol yang digunakan, yaitu:

– distance vector, dan
– link state.

Tutorial kali ini masih menggunakan packet tracer sebagai simulator.

Gambar topologinya sebagai berikut :

EIGRP

EIGRP

Dari gambar diatas kita ketahui bahwa terdapat 3 buah router yaitu “Cabang A”, “Cabang B” dan “Kantor Pusat”. Kita akan mengkonfigurasi masing-masing router agar dapat terkoneksi satu dengan yang lainnya dengan EIGRP.

Berikut konfigurasi interface masing-masing router :

Router ” Cabang A” :

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface s0/0
Router(config-if)#ip address 192.168.1.2 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#exit
Router(config)#

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.10.1 255.255.255.0
Router(config-if)#exit
Router(config)#

Router ” Cabang B “ :

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface s0/0
Router(config-if)#ip address 192.168.2.2 255.255.255.0
Router(config-if)#exit
Router(config)#

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.30.1 255.255.255.0
Router(config-if)#exit
Router(config)#

Router ” Kantor Pusat “ :

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface s0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#exit
Router(config)#

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface s0/1
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#exit
Router(config)#

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.20.1 255.255.255.0
Router(config-if)#exit
Router(config)#

Kemudian, kita konfigurasi masing-masing router untuk EIGRP routingnya.

Router ” Cabang A” :

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router eigrp 55
Router(config-router)#net
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.10.0
Router(config-router)#exit
Router(config)#

Router ” Cabang B” :

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router eigrp 55
Router(config-router)#net
Router(config-router)#network
192.168.2.0
Router(config-router)#network
192.168.30.0
Router(config-router)#exit
Router(config)#

Router ” Kantor Pusat “ :

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router eigrp 55
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.20.0
Router(config-router)#exit
Router(config)#

Setelah kita konfigurasi masing-masing router, maka jika kita ping dari PC ke PC yang lain meski beda network pasti  akan ada reply alias berhasil. Selamat mencobanya, dan semoga behasil.

Berikut screenshot dari PTnya :

Cabang A

Cabang A

Cabang B

Cabang B

Kantor Pusat

Kantor Pusat


Responses

  1. Terimakasih penjelasan beserta tutorialnnya

    sangat bermanfaat

  2. @ Uluf :
    Sama2, terima kasih sudah berkunjung


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Categories

%d bloggers like this: