Posted by: Barly Wicaksono | 16 October, 2009

Virtual LAN (VLAN) di Cisco

A virtual LAN, commonly known as a VLAN, is a group of hosts with a common set of requirements that communicate as if they were attached to the Broadcast domain, regardless of their physical location. A VLAN has the same attributes as a physical LAN, but it allows for end stations to be grouped together even if they are not located on the same network switch. Network reconfiguration can be done through software instead of physically relocating devices. (wikipedia)

——————————————————————————————————————————————————-

VLAN (Virtual LAN) merupakan suatu model jaringan yang tidak terbatas pada lokasi fisik seperti LAN , hal ini mengakibatkan suatu network dapat dikonfigurasi secara virtual tanpa harus menuruti lokasi fisik peralatan. Atau dapat dikatakan VLAN  berfungsi membagi Broadcast Domain suatu network.

Cisco Catalyst

Cisco Switch Catalyst

VLAN diklasifikasikan berdasarkan metode (tipe) yang digunakan, baik menggunakan port, MAC addresses dsb. Semua informasi yang mengandung pengalamatan suatu vlan (tagging) di simpan dalam suatu database (tabel), jika penandaannya berdasarkan port yang digunakan maka database harus mengindikasikan port-port yang digunakan oleh VLAN.

Untuk mengaturnya maka biasanya digunakan switch/bridge yang manageable atau yang bisa diatur. Switch/bridge inilah yang bertanggung jawab menyimpan semua informasi dan konfigurasi suatu VLAN. Switch akan menentukan kemana data-data akan diteruskan dan sebagainya. atau dapat pula digunakan suatu software pengalamatan (bridging software) yang berfungsi mencatat/menandai suatu VLAN beserta workstation yang didalamnya. Untuk menghubungkan antar VLAN dibutuhkan router. Dalam kasus ini kita menggunakan switch yang dapat berjalan di layer 2 & 3 sehingga tidak membutuhkan router.

Kali ini saya akan menggunakan packet tracer sebagai simulator, dalam kasus ini akan dibuat sebanyak 2 VLAN. Dan setiap client yang terhubung VLAN tertentu, tidak dapat terkoneksi dengan komputer pada network yang berbeda VLAN.

Berikut topologinya :

VLAN

Langkah pertama, kita set ip address tiap masing-masing PC, misalkan kita set seperti gambar diatas. Set ip manual pada pc dapat langsung melalui GUI. Lalu  port switch yang akan digunakan diberi alamat ip.

Main_Switch(config)#int fa0/1
Main_Switch(config-if)#ip address 192.168.1.1 255.255.255.0
Main_Switch(config-if)#exit

Main_Switch(config)#int fa0/2
Main_Switch(config-if)#ip address 192.168.1.2 255.255.255.0
Main_Switch(config-if)#exit

Main_Switch(config)#int fa0/3
Main_Switch(config-if)#ip address 192.168.1.3 255.255.255.0
Main_Switch(config-if)#exit

Main_Switch(config)#int fa0/4
Main_Switch(config-if)#ip address 192.168.1.4 255.255.255.0
Main_Switch(config-if)#exit

Kemudian kita masuk ke Switch utama untuk membuat nama pada masing-masing VLAN. Contohnya VLAN 10 diberi nama sepuluh, duapuluh dst.

Main_Switch(config)#vlan 10
Main_Switch(config-vlan)#name sepuluh
Main_Switch(config-vlan)#exit
Main_Switch(config)#vlan 20
Main_Switch(config-vlan)#name duapuluh
Main_Switch(config-vlan)#exit

Setelah kita beri nama masing-masing VLAN, saatnya mengelompokkan port secara manual berdasar nomor port.

Main_Switch(config)#int fa0/1
Main_Switch(config-if)#switchport access vlan 10
Main_Switch(config-if)#exit
Main_Switch(config)#int fa0/2
Main_Switch(config-if)#switchport access vlan 20
Main_Switch(config-if)#exit
Main_Switch(config)#int fa0/3
Main_Switch(config-if)#switchport access vlan 10
Main_Switch(config-if)#exit
Main_Switch(config)#int fa0/4
Main_Switch(config-if)#switchport access vlan 20
Main_Switch(config-if)#exit

Setelah kita kelompokkan masing-masing port pada area VLAN masing-masing, maka sekarang kita uji apakah sudah berjalan dengan baik pada switch.

Main_Switch#sh run
Building configuration…

Current configuration : 1093 bytes
!
version 12.2
no service password-encryption
!
hostname Main_Switch
!
!
interface FastEthernet0/1
switchport access vlan 10
!
interface FastEthernet0/2
switchport access vlan 20
!
interface FastEthernet0/3
switchport access vlan 10
!
interface FastEthernet0/4
switchport access vlan 20
!

interface Vlan1
no ip address
shutdown
!
line con 0
password cisco
login
!
line vty 0 4
password cisco
login
!
!
end

Dari keterangan diatas, masing-masing port kita pisahkan berdasarkan nomor VLAN yang telah kita buat. Lalu kita cek pengelompokannya.

Main_Switch#sh vlan brief

VLAN Name                                     Status    Ports
—- ——————————– ——— ——————————-
1    default                                          active    Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gig1/1, Gig1/2
10   sepuluh                               active    Fa0/1, Fa0/3
20   duapuluh                              active    Fa0/2, Fa0/4
1002 fddi-default                        active
1003 token-ring-default            active
1004 fddinet-default                active
1005 trnet-default                  active

Dari Running-config diatas telah didapat bahwa Fa0/1 & Fa0/3 ada pada VLAN 10 dan Fa0/2 & Fa0/4 ada pada VLAN 20.

Berikut ini screenshotnya :

VLAN Brief

VLAN Brief


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Categories

%d bloggers like this: