Posted by: Barly Wicaksono | 25 November, 2009

Routing OSPF di Cisco

Open Shortest Path First (OSPF) is a dynamic routing protocol for use in Internet Protocol (IP) networks. Specifically, it is a link-state routing protocol and falls into the group of interior gateway protocols, operating within a single autonomous system (AS). It is defined as OSPF Version 2 in RFC 2328 (1998) for IPv4. The updates for IPv6 are specified as OSPF Version 3 in RFC 5340 (2008).

OSPF is perhaps the most widely-used interior gateway protocol (IGP) in large enterprise networks; IS-IS, another link-state routing protocol, is more common in large service provider networks. The most widely-used exterior gateway protocol is the Border Gateway Protocol (BGP), the principal routing protocol between autonomous systems on the Internet.(wikipedia)

—————————————————————————————————————————————————————————————————————-

Kali ini saya akan memposting tutorial Dynamic Routing Protocol yaitu OSPF. OSPF merupakan singkatan dari Open Shortest Path First, dari artinya saja kita dapat mengartikan secara tidak langsung dari makna secara bahasa. Open = Terbuka, dimana Protokol routing ini terbuka bagi siapa saja.

OSPF merupakan sebuah routing protokol berjenis IGP(Internal Gateway Protocol) yang hanya dapat bekerja dalam jaringan internal suatu organisasi atau perusahaan. Jaringan internal maksudnya adalah jaringan di mana Anda masih memiliki hak untuk menggunakan, mengatur, dan memodifikasinya. Atau dengan kata lain, Anda masih memiliki hak administrasi terhadap jaringan tersebut. Jika Anda sudah tidak memiliki hak untuk menggunakan dan mengaturnya, maka jaringan tersebut dapat dikategorikan sebagai jaringan eksternal.
OSPF merupakan routing protokol yang menggunakan konsep hirarki routing, artinya OSPF membagi-bagi jaringan menjadi beberapa tingkatan. Tingkatan-tingkatan ini diwujudkan dengan menggunakan sistem pengelompokan area.

Langsung menuju tutorialnya :

Topologi OSPF

Topologi OSPF

Topologi diatas memiliki 3 router sebagai penghubung antar jaringan, sedangkan 4 client terhubung langsung tanpa menggunakan switch. terdapat 3 router yaitu : Jakarta, Serang, dan Cirebon.

—————————————————————————————————————————————————————————————————————-

Konfigurasinya :

Jakarta

Jakarta#sh run
Building configuration…

Current configuration : 892 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Jakarta
!
!
!
username cisco password 0 15 cisco
!
!
!
ip name-server 0.0.0.0
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface Serial0/0
description *** Ke Router Kanan ***
ip address 192.168.10.1 255.255.255.0
!
interface Serial0/1
description *** Ke Router Kiri ***
ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
router ospf 20
log-adjacency-changes
!
router ospf 1
log-adjacency-changes
network 192.168.20.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.3 area 0
!
ip classless
!
!
!
line con 0
line vty 0 4
password cisco
login
!
!
end

Serang

Serang#sh run
Building configuration…

Current configuration : 898 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Serang
!
!
!
username cisco password 0 cisco
!
!
!
ip name-server 0.0.0.0
!
!
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
description *** Ke Router Backbone ***
ip address 192.168.20.2 255.255.255.0
clock rate 64000
!
interface Serial0/1
no ip address
shutdown
!
interface FastEthernet1/0
ip address 10.10.20.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
router ospf 1
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
network 10.10.20.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.3 area 0
!
ip classless
!
!
!
line con 0
line vty 0 4
password cisco
login
!
!
end

Cirebon

Cirebon#sh run
Building configuration…

Current configuration : 852 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Cirebon
!

!
username cisco password 0 cisco
!
!
!
ip name-server 0.0.0.0
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface Serial0/0
description *** Ke Router Backbone ***
ip address 192.168.10.2 255.255.255.0
clock rate 64000
!
interface Serial0/1
no ip address
shutdown
!
interface FastEthernet1/0
ip address 10.10.20.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.10.20.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.3 area 0
!
ip classless
!
!
!
line con 0
line vty 0 4
password cisco
login
!
!
end

—————————————————————————————————————————————————————————————————————-

Pembuktian

OSPF Jakarta

OSPF Jakarta

OSPF Serang

OSPF Serang

OSPF Cirebon

OSPF Cirebon

—————————————————————————————————————————————————————————————————————-

Demikian tutorial ini, semoga bermanfaat.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Categories

%d bloggers like this: