Posted by: Barly Wicaksono | 26 September, 2010

Passive Interface RIP di Cisco

Passive interface adalah perintah yang dapat kita gunakan untuk mengontrol perkembangan update tabel routing. Cara kerjanya adalah dengan menjadikan suatu interface menjadi silent host atau dengan kata lain membiarkan interface tersebut tetap menerima broadcast dari interface yang aktif, sementara interface yang passive tidak memberikan broadcast ke neighbor.

Topologi

Topologi

Topologi diatas memiliki 4 router cisco : Jakarta, Surabaya, Semarang dan Serang. Sedangkan area Semarang memiliki client tersendiri.
Yang ingin kita jadikan silent host adalah interface serial0/1 (ip address 10.10.30.2) pada router Jakarta, sehingga tidak lagi memberikan broadcast data kepada router Surabaya (ip address 10.10.30.2).

berikut running configurationnya :

SurabayaSurabaya#sh run
Building configuration…
Current configuration : 612 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Surabaya
!
!
!
ip name-server 0.0.0.0
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0
description to Jakarta
no ip address
clock rate 64000
!
interface Serial0/1
ip address 10.10.30.2 255.255.255.0
!
router rip
version 2
network 10.0.0.0
!
ip classless
!
!
!
line con 0
line vty 0 4
login
!
!
end
JakartaJakarta#sh run
Building configuration…
Current configuration : 834 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
ip name-server 0.0.0.0
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0
description to Serang
ip address 10.10.10.2 255.255.255.0
clock rate 64000
!
interface Serial0/1
description to Surabaya
ip address 10.10.30.2 255.255.255.0
clock rate 64000
!
interface Serial0/2
description to Semarang
ip address 10.10.20.2 255.255.255.0
!
interface Serial0/3
no ip address
shutdown
!
router rip
version 2
passive-interface Serial0/1
network 10.0.0.0
!
ip classless
!
!
!
line con 0
line vty 0 4
login
!
!
end
Serang Serang>en
Serang#
Serang#sh run
Building configuration…
Current configuration : 602 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Serang
!
!
!
ip name-server 0.0.0.0
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0
description to Jakarta
ip address 10.10.10.1 255.255.255.0
!
interface Serial0/1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
!
ip classless
!
!
!
line con 0
line vty 0 4
login
!
!
end
Semarang Semarang#sh run
Building configuration…
Current configuration : 664 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Semarang
!
!
!
ip name-server 0.0.0.0
!
!
!
interface FastEthernet0/0
description to Client Semarang
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0
ip address 10.10.20.1 255.255.255.0
clock rate 64000
!
interface Serial0/1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
network 192.168.1.0
!
ip classless
!
!
!
line con 0
line vty 0 4
login
!
!
end

—————————————————————————————————————————————————————————————————————-

Jika anda ingin melihat proses broadcast routing tabel pada setiap router, karena routing yang saya gunakan adalah RIP maka anda dapat mengaktifkan fungsi “debug ip rip events”  pada router Jakarta dan Surabaya.

Surabaya

Surabaya#debug ip rip events
RIP event debugging is on
Surabaya#

Jakarta

Jakarta#debug ip rip events
RIP event debugging is on
Jakarta#

maka yang akan terjadi seperti ini :

Debug Jakarta
Debug Surabaya

Jika kita lihat 2 gambar diatas, maka terdapat perbedaan yang sangat mencolok yaitu aktifitas di router. Setelah passive interface di router Jakarta diaktifkan, maka interface Jakarta tidak akan mengirimkan update kepada ip 10.10.30.1 (interface Surabaya). Hal ini karena interface Jakarta menuju Surabaya diperintahkan untuk menjadi silence host.
Padahal jika Surabaya memberikan paket ping ke Jakarta, maka akan tetap terkoneksi.

Ping Surabaya

—————————————————————————————————————————————————————————————————————-

Perbedaan passive interface dan normal interface adalah seperti dibawah ini, karena Semarang tidak dikonfigurasikan passive interface maka akan tetap menerima dan mengirimkan update routing tabel kepada Jakarta.

SemarangSemarang#debug ip rip events
RIP event debugging is on
Semarang#
Debug Semarang

—————————————————————————————————————————————————————————————————————-

Demikian tutorial ini, semoga bermanfaat.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Categories

%d bloggers like this: